본문내용 바로가기 메인메뉴 바로가기 푸터 바로가기

취약점 정보

CVE-2021-26615 | 반디소프트사 ARK 라이브러리에서 발생하는 Integer overflow 취약점2021.11.25
□ 개요
o 반디소프트社의 압축 해제 모듈인 ARK 라이브러리에서 발생하는 Integer overflow 취약점
반디소프트社의 압축 해제 모듈인 ARK 라이브러리에서 발생하는 Integer overflow 취약점
취약점 종류 영향 심각도 CVSS 점수 CVE-ID
Integer overflow 원격 코드 실행 High 7.8 CVE-2021-26615
 
□ 설명
o 압축 해제 모듈인 ARK 라이브러리에서 Ark_NormalizeAndDupPathNameW 함수의 인자 값으로 들어온 문자열(경로정보) 크기에 대한 검증이 없어
integer overflow 발생
 
□ 영향받는 제품 및 버전
영향받는 제품 및 버전
제품 영향 받는 버전 환경
ARK 라이브러리 7.13.0.3 Linux Ubuntu
 
□ 해결 방안
o 취약한 버전의 제품 이용자는 ARK 라이브러리 버전 7.16.0.1이상으로 설치

□ 참고 사이트
o https://kr.bandisoft.com/ark/

□ 기타
o 취약점은 KrCERT 홈페이지를 통해 정재영님께서 제공해주셨습니다.


□ 작성 : 침해사고분석단 취약점분석팀